• Please post pictures and as much information as possible.

issue Nute Burn or Deficiency?

Hey all,

Starting to see some troubles in a good chunk of my plants. I'm thinking it's nute burn now that I'm seeing some brown spots as well and not just the yellowing, and a little bit of deformity on new growth. Also, the older batch of plants I have have been getting the same water/nutes but look great with no issues.

I normally start out a little less hot on the nutes (around 3-5ml/gal) but figured I try a bit more this year and see how it goes. (which is why I'm figuring its nute burn)

The first two weeks were water only, since then I've been watering with water PH'd to around 6.3 to 6.5 with 10ml per gallon of CNS17 Grow (3-1-2) and 2ml per gallon of Cal-Mag (2-0-0).

Ambient conditions are around 70°F w/lights on (18-6), 50%RH.

Just looking for confirmation or other thoughts. What say you guys and gals?


Thanks!



95defc85337752e688654eb62460ae3b.jpg


44080b9f93af0f67fcc77a148a56038a.jpg


6b4701340c4dfb4d23f6156ee35009c1.jpg


ee33fd07ff770ab94d0b9bc7f4dc80b4.jpg
 
Solution
Update for anyone who comes across this thread at a later date: I've been watering them with just PH balanced water still, so about a week now. I water them every day or two and the new growth seems to be better already so it looks like it was for sure nute burn.

PaulG

Extreme Member
You may be right about the nutrients. If it's
only the young plants showing the discolora-
tion, the nutrients may have been too much
to start with.
 
Maybe a little H2O flush?
 
Yeah I watered them yesterday with just ph balanced water and zero nutes. I'll continue water only for the next week or two and see how they look then.
 
Top