issue Yellow newgrowths

Hi,after winning a fight againts aphids, I now have a whole new problem at hand, my leaves now have yellow spots on them (Bacterial leaf spots)? Or am I just overreacting, and the newgrowths are yellow, the bottom leaves are fine (except that it has the faint yellow blotches) its just the top newgrowths that are yellowing.

The first picture is a picture of the yellow newgrowths, while the second shows you the faint yellow blotches, it can be a bit hard to see the blotches, but if you look at the bottom half of the leaf you can see it.

I really dont want to immediately use fertilizers (I dont have organic fertilizers and the plants are still quite young) without a confirmation that its a nutrition deficiency.

Any idea on whats causing it? And what can I do to fix it? (I've just topped my peppers and theyre carolina reapers)
 

Attachments

  • IMG_20211101_123142.jpg
    IMG_20211101_123142.jpg
    67.9 KB · Views: 20
  • IMG_20211101_122512.jpg
    IMG_20211101_122512.jpg
    73.3 KB · Views: 21
Last edited:

CaneDog

Extreme Member
Deggy I don't see anything to worry about, at least not right away. The chlorosis you're seeing isn't any disease and it's definitely not BLS. If you share some more info like your what type of soil/media you're using, your lighting setup, etc., it may help people figure out what's up. Sometimes newer leaves come in a bit pale, then green up. If they don't, I'd be thinking about a modest dose of fish fertilizer, but that's just my best guess at this point.
 
Deggy I don't see anything to worry about, at least not right away. The chlorosis you're seeing isn't any disease and it's definitely not BLS. If you share some more info like your what type of soil/media you're using, your lighting setup, etc., it may help people figure out what's up. Sometimes newer leaves come in a bit pale, then green up. If they don't, I'd be thinking about a modest dose of fish fertilizer, but that's just my best guess at this point.
Thanks, turns out I indeed was just overreacting, its not a disease, just figured out that my soil ph is 8.... Yep I've actually read the indicators the wrong way around, this whole time i thought my soil was acidic.
Basically I mistook alkaline as acidic :scared: , im going to get some citric acid and sulfur today hopefully it'll help.

Again thanks everyone and sorry for being overly worried, its my first time planting these ;).
 
Hello Ive got an update on the plants, theyre doing much better now! Gave them some foliar spray to help with the nutrient uptake, soil is still base but it went down by 1 ph, its rainy season now, and aphids are gone even without neem oil. 2 of the plants even started growing flowerbuds!

But the newgrowths look a little weird, not sure if its a cause for concern.

Here's some of the pictures i took if you want to see their progress :) (sorry for the bad quality pics, got to make them fit the web's max file size)
 

Attachments

  • IMG_20211126_083908.jpg
    IMG_20211126_083908.jpg
    67.9 KB · Views: 7
  • IMG_20211126_083926.jpg
    IMG_20211126_083926.jpg
    47.6 KB · Views: 7
Last edited:
Top